cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Xiaomi Redmi Note 13 not getting service

So I my friend just got a new phone after his old one was stole, ordered new sim, everything works fine, inserted the sim and it can't get any service, tried everything I found online but nothing seems to be working.

I tried all of the airplane mode on-off, restart, reinsert sim, reset network settings, change preferred network type, etc. None of those work, one that I couldn't try was calling "#*#*4636#*#" but that's because there is literally no signal, the network bar has an X on it so it won't do that.

Some info... It's a Xiaomi Redmi Note 13, it's on MIUI 14, I have a 48 sim in my phone and it works fine so it's not an area problem, the sim is brand new and so is the phone so no faulty hardware (believe me I checked), Network settings are correct since they were automatically set, I did have a weird thing where I couldn't manually choose the network as Three 4g (48) but it worked again when I set it back to automatic.

That's all the information I can think to give, really hope someone has some magic fix, thanks!

3 REPLIES 3

dalyer
The Legend
The Legend

Your post is a bit confusing.

> everything works fine

> but it worked again when I set it back to automatic.

What exactly isn't working?

If you need to contact 48 support about this then see the link in my signature below or email them at support@48months.zendesk.com

Where was the phone bought?

Could it be locked to another network?

Could it be a China/India model that doesn't support frequencies used in Ireland/Europe?


I am not a 48 employee - if you need to contact 48 support then please click here - if the Chat Now option does not appear on that page then keep trying until it does.

Sorry that my post is confusing, when I said ‘worked fine after I set it back to automatic’, I meant that it actually had a network registered, but it wouldn’t register to any in manual mode, regardless of whether it was registered or not, it wasn’t getting any signal.

As for the model, it was bought at Harvey Norman, so it’s European, and the phone wasn’t locked to a network.

What isn’t working is that it’s not getting any signal even if everything is set up correctly

In that case I would bring it back to Harvey Norman and ask them to advise.


I am not a 48 employee - if you need to contact 48 support then please click here - if the Chat Now option does not appear on that page then keep trying until it does.