Showing results for 
Show  only  | Search instead for 
Did you mean: 

Nothing happens when I click on a plan



I am a member already but my CC expired. I have entered a new CC succesfully but it still says I have no plan. When I click on the plan I want nothing happens. I have tried repeating this in various browsers.

Can anyone help please?

Thanks 🙂



Sorted. It doesn't go to another page but if you scroll down more options appear. 🙂

The Legend
The Legend

Edit: ignore this post as the issue was resolved by the time that I posted it. 

If your CC expired and auto-renewal failed then you need to buy a membership plan manually for this month before auto-renewal takes over again next time around.

Are you saying that when you try to do this you cannot buy a plan?

I presume that you're using this page?

What exactly happens step by step? 

Any error messages?

Have you tried the app instead of the website in case that makes any difference?

If you need to contact 48 support about this then see the links in my signature below.

I am not a 48 employee - if you need to contact 48 support you can do so by chat, email ( or phone.